Zastosowanie wybranych funkcji logicznych w Excelu

FUNKCJE LOGICZNE

Funkcje logiczne - służą najczęściej do testowania warunków, które powinny spełniać wartości zapisane w komórkach arkusza. Rzadko kiedy stosuje się je samodzielnie, najczęściej są one zagnieżdżane w formułach, pełniąc rolę argumentów dla innych funkcji.

FUNKCJA JEŻELI

FUNKCJA JEŻELI - funkcja sprawdza warunek logiczny podany w pierwszym argumencie funkcji. Jeżeli jest on spełniony (PRAWDA), w wyniku zwracana jest wartość drugiego argumentu, a jeżeli nie (FAŁSZ) – wartość trzeciego argumentu.

Składnia funkcji JEŻELI:

test_logiczny

sprawdzany warunek logiczny. Jest to wartość lub wyrażenie, którego wynik można oszacować jako wartość logiczną(PRAWDA lub FAŁSZ).

wartość_jeżeli_prawda

drugi argument funkcji jest tak naprawdę wartością zwracaną w sytuacji, gdy pierwszy argument test_logiczny jest spełniony.

wartość_jeżeli_fałsz

trzeci argument funkcji jest wartością zwracaną w sytuacji, gdy pierwszy argument test_logiczny zwraca w wyniku wartość FAŁSZ.

Przykład zastosowania funkcji JEŻELI

FUNKCJA ORAZ

Funkcja ORAZ

współdziała z funkcją JEŻELI,rozszerzając jej działanie. JEŻELI w czystej postaci operuje tylko jednym warunkiem logicznym, natomiast ORAZ pozwala na wprowadzenie maksymalnie 30 warunków logicznych. Aby funkcja zwracała w wyniku wartość PRAWDA, konieczne jest, aby każdy z warunków, argumentów funkcji, był spełniony. Jeżeli chociaż jeden z przyjętych warunków ma wartość FAŁSZ, funkcja zwraca w wyniku FAŁSZ. ORAZ jest więc, inaczej mówiąc, iloczynem(koniunkcją) warunków.

Przykłady zastosowania funkcji ORAZ wraz z JEŻELI

Formuła:

=ORAZ(A2>1;A2<100)

Wyświetla wartość PRAWDA, jeśli wartość w komórce A2 jest większa niż 1 ORAZ mniejsza niż 100. W przeciwnym razie wyświetla wartość FAŁSZ.

Formuła:

=JEŻELI(ORAZ(A2<A3;A2<100);A2;"Wartość jest spoza zakresu")

Wyświetla wartość znajdującą się w komórce A2, jeśli jest ona mniejsza niż wartość znajdująca się w komórce A3 ORAZ mniejsza niż 100. W przeciwnym razie wyświetla komunikat „Wartość jest spoza zakresu”.

Formuła:

=JEŻELI(ORAZ(A3>1;A3<100);A3;"Wartość jest spoza zakresu")

Wyświetla wartość znajdującą się w komórce A3, jeśli jest ona większa niż 1 ORAZ mniejsza niż 100. W przeciwnym razie wyświetla komunikat. Można podstawić dowolną treść komunikatu.

FUNKCJA LUB

Funkcja LUB

podobnie jak funkcja ORAZ – współdziała z funkcją JEŻELI, pozwalając natworzenie bardziej rozbudowanych testów. Aby funkcja zwracała w wyniku wartość PRAWDA,konieczne jest, aby przynajmniej jeden z warunków,argumentów funkcji, był spełniony. Jeżeli wszystkie z przyjętych warunków mają wartość FAŁSZ, funkcja zwraca w wyniku FAŁSZ. LUB()jest więc, inaczej mówiąc, sumą (alternatywą)warunków.

Przykłady zastosowania funkcji LUB wraz z JEŻELI

Formuła:

=LUB(A2>1;A2<100)

Wyświetla wartość PRAWDA, jeśli wartość w komórce A2 jest większa niż 1 LUB mniejsza niż 100. W przeciwnym razie wyświetla wartość FAŁSZ.

Formuła:

=JEŻELI(LUB(A2>1;A2<100);A3;"Wartość jest spoza zakresu")


Formuła:

=JEŻELI(LUB(A2<0;A2>50);A2;"Wartość jest spoza zakresu")

Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book.

Pytanie

Czy do funkcji logicznych należą jeszcze jakieś funkcje oprócz wymienionych? Jak tak, to jakie?